Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 29, 2024 - 00:30 WIB
Scheduled
Dear Customers,
Our QRIS partner will be doing a scheduled maintenance
Date : Friday, November, 29 2024 Time : 00.30 - 04.30 Jakarta Time Duration : 4 Hours Impact: Payment made towards QRIS during this period might be stuck in processing. During this maintenance, Please refrain from doing QRIS Transactions for the maintenance period
Posted Nov 28, 2024 - 20:14 WIB
This scheduled maintenance affected: Payment Methods (QRIS).