Partial disturbance of Disburements to BCA Provider I
Incident Report for Durianpay
Resolved
This incident has been resolved.
Posted Oct 09, 2024 - 11:47 WIB
Identified
We have been notified by one of the providers that they are having an issue with Top Up Balance via BCA. We are currently monitoring and will update as soon as we hear an update from our provider.
Posted Oct 09, 2024 - 10:37 WIB
This incident affected: Top Up (VA BCA).