Partial disturbance of Disbursements to BNI on Provider 2

Incident Report for Durianpay

Resolved

This incident has been resolved.
Posted Apr 11, 2026 - 12:59 WIB

Identified

Our provider has confirmed an issue affecting disbursements to BNI via Provider 2.
Posted Apr 11, 2026 - 12:27 WIB
This incident affected: Disbursements (Disbursements - BNI).