Partial disturbance of Disbursements to BCA (Provider I)
Incident Report for Durianpay
Resolved
This incident has been resolved.
Posted Sep 30, 2024 - 11:07 WIB
Identified
We have been notified by one of the providers that they are having an issue with disbursements for Top Up Balance Via BCA. We are currently monitoring and will update as soon as we hear an update from our provider.
Posted Sep 30, 2024 - 10:25 WIB
This incident affected: Top Up (VA BCA).