Major Disturbance on Checkout and Payment Link
Incident Report for Durianpay
Resolved
This incident has been resolved.
Posted Nov 29, 2024 - 10:06 WIB
Identified
We have identified Checkout and Payment Link are currently having problems. Our team is working on a fix for this issue and will update it if it is resolved.
Posted Nov 29, 2024 - 09:24 WIB
This incident affected: Checkout.