Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 13, 2025 - 01:00 WIB
Scheduled
Dear Customers,
We were informed that BCA VA will be having a planned maintenance scheduled at:
Start: April 13, 2025 01:00 AM End: April 13, 2025 06:00 AM Duration: 5 Hours
Impact: During this maintenance, no payment transactions through BCA VA can be processed. Please avoid transaction to this channel while the maintenance is ongoing.
Posted Apr 12, 2025 - 18:00 WIB
This scheduled maintenance affected: Payment Methods (Virtual Account - BCA).