Partial disturbance of Disburements to BSI on Provider 1
Incident Report for Durianpay
Resolved
This incident has been resolved.
Posted Apr 13, 2024 - 22:55 WIB
Identified
We have been notified by one of the providers that they are having an issue with disbursements to BSI. We are currently monitoring and will update as soon as we hear an update from our provider.
Posted Apr 13, 2024 - 21:43 WIB
This incident affected: Disbursements (Disbursement - BSI).