Partial disturbance of Disbursements to BSI on Provider 1

Incident Report for Durianpay

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 01:04 WIB

Identified

We have been notified by one of the providers that they are having an issue with disbursements to BSI. We are currently monitoring and will update as soon as we hear an update from our provider.
Posted Mar 26, 2025 - 00:00 WIB
This incident affected: Disbursements (Disbursements - BSI).