Partial disturbance of Disburements to BCA Provider II
Incident Report for Durianpay
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 18:09 WIB
Identified
We have been notified by one of the providers that they are having an issue with disbursements to BCA. We are currently monitoring and will update as soon as we hear an update from our provider.
Posted Apr 16, 2024 - 17:10 WIB
This incident affected: Disbursements (Disbursements - BCA).