Partial disturbance of Disbursements to BTN on Provider 2

Incident Report for Durianpay

Resolved

This incident has been resolved.
Posted Jul 04, 2026 - 15:41 WIB

Investigating

We are currently investigating this issue.
Posted Jul 04, 2026 - 15:20 WIB
This incident affected: Disbursements (Disbursements - Other Banks).